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This online help will assist you in understanding and using Wordfast Professional (Wordfast Pro).

It contains step-by-step procedures of Wordfast Pro functions.

This help is a reference for project managers and translators. The audience must be familiar with

basic translation terminologies.

The help is organized as follows:

Section Contents

Section 1 Overview of Wordfast Pro and workflows
providing a snapshot of Wordfast Pro
functions.

Section 2 Procedure for installing Wordfast Pro.

Section 3 Procedures for opening Wordfast Pro and a
brief description of the PM and TXML editor
perspectives.

Section 4 Procedures for PM plug-in tasks.

Section 5 Information on basic menu options.

Section 6 Procedures for managing translation
projects.

Section 7 Information on shortcut keys and license
management.

Section 8 Information on common errors and their
solutions.

Section 9 Procedures for working with Wordfast
Aligner.

Section 10 Procedures for working with TM

Page 6 of 148



About the User Guide

Section

Contents

Administration perspective.

All user actions are highlighted in bold to help understand the procedures better.

Images are inserted at appropriate places to help you relate to the application interface.

The term "Note" precedes any important information that you may need to know while

performing a task.

The word "Optional” follows procedural steps that are not mandatory.

I "H#

Term Description

™ Translation memory

TXML Tracker Extensible
Markup Language

XML Extensible Markup
Language

HTML HyperText Markup

Language
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Wordfast Pro is a java-based translation and editing application designed to improve the way in
which translators work. It presents translators with a collaborative environment where translation
memory (TM) files can be accessed quickly and efficiently. Wordfast Pro is a flexible application
that can work with desktop TM files or interact directly with a powerful TM server application. It

can also operate as a stand-alone tool to supplement existing translation workflows.

% n
The key advantages of Wordfast Pro are as follows:

TM compatibility: Tabular TM format allows for simple integration of Trados, SDLX or

Déja Vu TM files.

Format flexibility: Native format is TXML, an XML-based pivot format. Filters exist for
DOC, PPT, XLS, PDF, HTML, MIF, INX, JSP, RC and TTX files. Wordfast Pro supports

only those TTX files that are translated and segmented using tag editor.

Collaborative environment: Users can interact with TM Server and share translation

memory assets in real-time.

Automated editing: Multi-lingual spell checkers and terminology recognition improves the

speed and accuracy in the review process.

Administrative security: Managers can assign specific rights and privileges to individual

translators or linguistic teams.

Wordfast Pro provides an intuitive, collaborative environment where translators can deliver higher

quality in-language content with greater consistency and efficiency.

& () $ *+(9

Find below the workflow diagram for PM plug-in:
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About Wordfast Pro

| Formats

Files for translation Select/Add format

Upload conversion rules

Conversion rules

Translated files
submitted to client

Project Manager Plug-in

Analyze

Analyze against TM
Pre-translate
{Optional)

Cleanup

Remove source
segments

| Files sent to
| translators for
| translation
Extract |
Extract repetitive |
content from files I—D-

(Optional)

A

Update TM

r
Translated files returned
to PM with source and
target segments

Note: The Extract frequents option is available in the Wordfast Professional Plus version only.

$ *+($

Find below the workflow diagram for TXML editor:

r— " = === —— = 1
| TXML Editor :
! Prepare Translate Savef/Update :
|
| Create/Open project Tr(:f;:g:le Save file |
Create/Open TM Add terminology (Op) ] )
> Import terminology Lev;?:e:ea?e?;::\qolo Add TM (Op)
Define penalties 2 e Save project
Use Spell check

Files for translation
received

|
|
| Translated files
| submitted to PM
|
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This section includes basic information that will help you get started with Wordfast Pro.

System requirements

Installing and activating Wordfast Pro

Opening Wordfast Pro

Wordfast Pro homepage

“H#H O #

The minimum system requirements are:
Operating system: Windows XP or higher, Mac OS 7 or higher (including OS X) or Linux
Processor: 1.6 GHz
RAM: 1GB

Hard disk space: 200MB

(( +

To install Wordfast Pro:

1. Download the Wordfast Pro installer from the webpage
http://www.wordfast.com/store_download.html to your PC.

2. Run the installer.
The Wordfast Pro Demo Mode appears.
Note: Wordfast Pro requires a Java JRE to be installed on your PC. During installation, if
Java JRE does not exist, it will be installed for you. If it exists, then Wordfast Pro will refer
to it when running.
In the Demo Mode, you can view and test all the functions of the software. You can
purchase a Wordfast Pro license from the webpage
http://www.wordfast.com/store_download.html.
If you do not purchase a license, you are limited to storing up to 500 translation units in
your translation memories.

To activate a Wordfast Pro license:

1. Purchase a Wordfast Pro license from the webpage
http://www.wordfast.com/store_download.html.

The license file is sent to you via email.
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Getting started with Wordfast Pro

© ® N o v

Save the license file to a known location, preferably C:\Program files\Wordfast Pro.
Open the Wordfast Pro Demo Mode.

Click Help > License Management .

The Activation dialog box appears.

Click License Manager .

Select (Re-)Install a license certificate  and click Next.

Browse and navigate to C:\Program files\Wordfast Pro and select the license file.
Click Next twice and then Finish .

Restart Wordfast Pro.
Your license is active. If you have any problems with the license and require support,

please log into the Wordfast Pro support hotline at www.wordfast.com.

+

To open Wordfast Pro, you have two options:

Double-click the Wordfast Pro shortcut on your desktop.

Or

Go to C:\ > Program Files > Wordfast Pro

The Wordfast Pro homepage appears.
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Getting started with Wordfast Pro

|| Wordfast

FEX
File Edit Translation Memory Terminology  \Window  Help
] 4 '
ﬁ = 8 || 5= outline 52 =i{m
Il 2| An outling is not available.

)

" TM Lookup 52 | 2 Txml Context | | Motes =iim

I

| | [ Find In Source ] l Find In Target ] l Clear

| I |Source |Target | T Mame

10Mof et ([

+ 0 #

The Wordfast Pro homepage is the work space for translators to work on translation projects. The

homepage directs you to two perspectives:
PM perspective

TXML editor perspective

PM PERSPECTIVE

Find below a sample PM perspective screenshot:
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Getting started with Wordfast Pro

¥ | Wordfast
Fil= Edit ‘Window Help
A 3 4
= &em - g
A
||| Anahvze’ |Extract Frequents | Cleanup | 5
1m 2 _—
T Preferences
File narne Extension 0
Symbolic Mame TM Type Source Target Warkgroup ID
1 1 Local English...  Spanish... |
O mz Local English...  Spanish...
] ™3 Local English...  Spanish...
] a4 Local English...  Spanish...
O s Local English...  Spanish...
[] e Local English... German...
0 mz Local English... Spanish...
S >
Options
[v]Pretranslate | 100 % | % Matches
2ok
() Output in comma separated Format
csv |
< b3 () Output only report summary
aMofeam [ ¢

Find below the description for the various components of the PM perspective:

Number Use to...
1 PM view the PM perspective. The PM perspective is
= . :
perspective the workspace for project managers to process
icon files before and after translation. Go to Using PM
plug-in for more information.
2 | Analyze tab analyze files for translation against a TM to
=] ,
leverage reusable content and pre-translate files.
Go to Analyzing files for more information.
3 | Extract extract recurring segments in the files. Go to
e . : .
frequents Extracting frequents for more information.
tab Note: The Extract frequents option is available in
the Wordfast Pro Professional Plus version only.
4 Cleanup tab cleanup the file and update the TM after
el L :
translation is complete. Go to Cleaning up for
more information.
5| ™ create or open a translation memory.
ol
Preferences
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Getting started with Wordfast Pro

TXML EDITOR PERSPECTIVE

Find below a sample TXML editor perspective screenshot:

|| Wordfast
2‘”'—’ File Edit Translation Memory Terminology ‘Window  Help
S @
E = EE Outline &3
"-Lll—H|f_| &n outline is not available.
2
kL
s>

Py

5_1—-’ 7 TMLagkup 52 | 2 Txml Cantesxt

| Maotes

L

I [ Find In Source ] [ Find In Target ] [

Clear

EEX

| jin] |Source

Target | TM Mame

1o0Mof &4t [ ©

Find below the description for the various components of the TXML editor perspective:

Number Use to...
1_| Title bar view the project name.
2_| Menu bar carry out all the functions, some of
which are also included in the tool
bar. Go to TXML editor menu options
for more information.
3_| Tool bar quickly complete common functions.
You can rollover the shortcut icons to
see its function.
4_| TXML view the TXML editor perspective.
perspective The TXML editor perspective is the
icon workspace for managing translation

projects. This perspective allows you

to translate files by leveraging
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Getting started with Wordfast Pro

Number Use to...
translation memory and terminology.
Go to Managing projects for more
information.

5 Main translate a file. This is the work space
translation for translating files. Go to Translating
window in a project for more information.

6 TM Lookup view TM leverage results and context
window searching. You can either search for a

term or a phrase and the source and
target segments appear in a table
format. Go to Using TM Lookup
window for more information.

7 Txml view the TXML context of the
Context currently open file. Go to Viewing

TXML Context for more information.

8 Notes view, edit and delete notes specific to

' each segment. Go to Using notes for
more information.

9 Outline quickly navigate a file from one

' window source segment to another. Go to

Using Outline window for more

information.
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The Project Manager plug-in includes tasks that prepare files for translation. The preparation

process includes the following tasks:

Receiving files and rules

Setting up filters

Analyzing files

Extracting frequents

Cleaning up and updating translation memory

+( (

This is the first step towards preparing files for translation. Find below a brief description of files

and conversion rules:

Files: These are received from clients for translation. They may be in any format, such as
DOC, XLS, PPT, INX, HTML, JSP and so on. When you open any one these files in

Wordfast Pro, it is automatically converted to TXML.

Conversion rules: These rules are required for creating a new XML filter to convert XML

files to TXML. The rules file is provided to you by the client.
+ (

A filter defines the working parameters for different types of files received for translation. A filter
can be selected from the available list or a new format created. Please note that the process to
add MS Excel files is different from the other file filters. Additionally, Wordfast Pro supports only
those TTX files that are translated and segmented using tag editor. The TTX files must be

renamed to match the source format if they need to be viewed in tag editor.

Find below the procedures for the following tasks:

Viewing default file filters

Adding new file filters

Adding an Excel file filter

Selecting FrameMaker filter preferences
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Using PM plug-in

VIEWING DEFAULT FILE FILTERS

A number of filters are pre-configured for your convenience. For example, if you choose the
Default Java Properties Filter, the Encoding UTF-8 is automatically selected.

To view a default file filter:

1. Open Wordfast Pro and click Edit > Preferences > Translations > Filters > Forma ts.

The Formats dialog box appears. The default filters appear in the Available formats box.

Preferences [Filtered)

E_lg}f_pE_FiIter ket | S

= General
[=)- Bppearance
Colors and Fonts
Views
Kevys
Memory Preferences
= Spelling
Hunspell
Temp Filas
=) Translations
Auto-Propagation
Colors
[=)- Filters
Formats
FrameMaker Filter Preferences
rMachine Translation
PM Plug-in
Seqgrientation Sektings
= Terminology
Blacklist
Terminology Lisk
T Administration
=) Transcheck
Forbidden Chars
Partial
Punctuations
Unkranslatable
[=) Translation Memory
Local
Penalties
Rernake

Formats

Awailable Formats

- BX

“= Default ASP Filker

[ Default Excel 2007 Filker

B pefaul Excel Filker

@ | Default HTM Filker

®  Default HTML Filker

=\ Default MY Filker

i Default 15P Filker
Default Java Properties Filker
« Default MIF Filker

FEIDeFault POF Filter

DeFauIt PowerPaint Filkey
ZlDefault RTF Filker

« Default TTx Filker

« Default T=LF Filter

"= Default T2T Filter

[{# DeFault word 2007 Filker

B Default word Filker

e

‘ Renarne

[Restore Defaults ] l Apply ]

[ [0 H Caniel ]
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Using PM plug-in

2. Select a default filter of your choice. For example, if you select Default HTML Filter, the

options for HTML files appear in the Options box as shown below.

Preferences (Filtered)

type fiter text | Gk Formats
i Gorperd Available Formats
(=) Appearance
Colors and Forts == Default ASP Filker Maw

Yigws [, Default Excel 2007 Filker

Kews EHDefaul Excel Fiter
Memary Preferences @ | Default HTM Filker

(= Speling L | Default HTML Filker
Hunspel ~+ Defaulk INX Filker
Temp Files i Default ISP Filker
(=) Translations Default Java Properties Filker
Auto-Propagation «.. Default MIF Filter
Colars ) DeFault POF Filker
[=)-Filkers

DeFauIt PowerPoint Filber
ZlDefault RTF Filker
«+ Defaulk TT¥ Filker
. Defaulk THLF Filker
"= Defaulk TXT Filter
i Default word 2007 Filer

Formats
FrameMaker Filker Preferences
IMachine Translation
P Plug-in
Segmentation Setkings
(=) Terminology

EBlacklist Iﬂ:ﬂ Default Word Filker
Terminology List Options

Tr Adrninistration

[=)- Transcheck
Forbidden Chars
Pattial
Punctuations
Untranslatable

[=)- Translation Memary
Local
Penalties
Remote

Encoding: | UTF-&

]

[ Restore Defaults ] [ Apply ]

[ ] 8 H Cancel ]

3. Ifrequired, you can modify the default options.

ADDING NEW FILE FILTERS

If the filter of your choice is not available in the default option, you can add a new filter. For
example, for XML and Excel filters you will need to provide additional information.

To add an XML filter:

1. Follow steps 1 and 2 from Viewing default file filters.

The Formats dialog box appears. The default filters appear in the Available formats box.
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Using PM plug-in

Click New.

The New Format dialog box appears.

Filters

Filter Type: | Iy Filter A
b 5P Filker

E Java Properties Filber

Pu:uwerPDint Filker

. ! Text based Filker
B word 2007 Filker

B word Filker

|

[ K ] [ Cancel

Select the XML Filter Type and click OK.

The New XML Filter appears in the Available Formats box.

Preferences [Filtered)

|t3-'pe filber bext | [EN

= General
= Appearance
Colors and Fonts
Views
Eeys
- Memory Preferences
= Spelling
-~ Hunspell
Temp Files
=) Translations
Auko-Propagation
Colors
[=}- Filters
Formaks
Framemaker Filter Prefs
- Machine Translation
P Plug-in
Segrmentation Settings
= Terminology
Terminology Mernory
TM Administration
Transcheck
[=) Translation Memory
Local
Penalties
Remote

Formats

Available Formats

“= Diefault ASP Filker

% Default Excel 2007 Filter

@__]Default Excel Filker

® | Default HTM Filter

® | Default HTML Filker

«+' Default INX Filker

i3 Default 15P Filker
Default Java Properties Filker
«: Defaul MIF Filker

| Default POF Filker

Default PowerPoint Filker
SilDefault RTF Filker

wit Default TTX Filker

«« Default TELF Filker
i Default word 2007 Filker
B Default Ward Filker

Cptions

e

Rename

Remaove

Encoding: | UTF-8

Conversion rules: |

Extension: | * el

[Restnre Defaults] [ Apply ]

H Cancel ]
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Using PM plug-in

4. Select the filter and click Rename, to change the filter name.
Select the Encoding as UTF-8.
6. Browse and select the Conversion rules file.
Note: The conversion rules file includes commands describing the content to be

translated in the XML files. Find below an example rules file.

! XML.properties - Notepad |Z||E|fg|
File Edit Faormat Yiew Help

# —*~ java-properties-generic —%—
comverter.regexp. collapsetags=False

# Include HTML Elements
glementIncludeHtm]=trus

# Known Elements

elementLocation.l=/tables/row
elementHand1ling. l=dont-translate
elementLocation. 2=/tablesrow coTumn
glementHand1ling. 2=dont-translate

# Extraction Rules For Known Elements

paragraphPrefix. 0=<column name=[A=]+7 translate="yes" [A>]+7> [A<]+7< I [COATANY [
paragraphsuffix. =" ] >

paragraphFormat. O=htm]-embedded|

7. Click Apply and OK.
A new XML filter is set up.

ADDING AN EXCEL FILE FILTER
To add an Excel file filter:

1. Follow steps 1 and 2 from Viewing default file filters.

The Formats dialog box appears. The default filters appear in the Available formats box.
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Using PM plug-in

Select Format Type as Default Excel Filter.

The Excel Filter options appear.

Preferences (Filtered)

[ ’ =
|bype filker bext [ Sae

[=) General
[=)- Appearance
Colors and Fonts
Wiews
Kevys
- Memory Preferences
= Speling
~Hunspell
Temp Files
[=) Translations
Auto-Propagation
Colors
[=)- Filkers
Formats
FramemMaker Filker Prefe
- Maching Translation
PM Plug-in
Seqgrnentation Settings
[=)- Terminolagy
Terminology Memory
T Administration
Transcheck
[=)- Translation Memory
Local
Penalties
Rermoke

|
o

Formats

fvailable Formats

“= Default ASP Filker
[ Default Excel 2007 Filker

E Default
®  Defaulk HTM Filker

® | Default HTML Filker

«+ Default TN Filker

il Default J5P Filker
Default Java Properties Filter
«+ Default MIF Filter
| Default POF Filker
DeFauIt PowserPoint Filker
S Default RTF Filker

=+ Default TTH Filker

«+ Default TELF Filter
i Default word 2007 Filker
BDefault word Filker

Cptions

Configuration: Simple
Sample File: none

Clear ] [ Setup

Rename

Remaove

T

[Restore Defaults l [

Apply ]

I

Zancel ]
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Using PM plug-in

Click Setup.
The Choose Excel file... dialog box appears.

Choose Excel File...

Lok in: | 759 Excel configuration V| ] ? e
Ty B Status-report1 s
| :3 B status-reportz. xls
My Recent
Documents
Frs
L
Desktop

My Documents

5

Iy Computer

File name:

— |

My Mebwork Files of type: |E:-:c:e| File vl [ Cancel l

Select an Excel file and click Open.
The Excel column selection wizard Instructions page appears.

Excel column selection wizard

Welcome to Excel Column Selection Wizard

The Excel Column Selection wWizard simplifies the Excel file translation process,
The subsequent screens are as Follovs:
1. *Select Wizard Twpe® is used to select Simple or Advanced wizard,
Simple Wizard: allows wou to select a row as the column header For translation
Advanced Wizard: allows vou ko select a row as the column header and choose the columns For kranslation. Tt also

creates a Target column where the translaked text will appear,

2. *Preview page™ models an Excel document. There are tabs corresponding bo each Excel sheet. Each tab contains
the following:

Murber of preview rows drop down lisk: to choose the number of rows ta be viewed
IJse header check box: bo select the Excel sheet headers as column header during translation
Table: with the Excel sheet contents

3, *3election page {(Advanced Onky* is used ko select columns For branslation,

4, *Reqgular expression page (Advanced Only)* is used ko provide a pattern ko markup any embedded HTML or
wvariables in the column,

Mexk = | l Finish ] [ Cancel
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5. Read the instructions carefully and click Next.

The Select wizard type page appears.

I#| Excel column selection wizard

Please select Wizard type.

Please chonse Wizard bvpe:
(*) Simple Wizard
() Advanced Wizard

l < Back ]| Mext = |’ Finish ” Cancel

6. Select the wizard type. You have two options:
Simple: selects all rows with content for translation

Advanced: allows you to choose the columns for translation. It also creates a

Target column where the translated text will appear.

Simple wizard
To run the Simple wizard:

1. Follow steps 1 to 7 from Adding an Excel file filter.
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2. Select Simple wizard and click Next.

The Preview page appears.

|f| Excel column selection wizard

Preview page

Flease select table row to use as column header,

| sheetl |sheet2 | sheet3

Flease choose number of preview raws, |10 | use headers?
1 Date Day Bckivity Tire taken
2 9f8/2008  Monday Induction 4

3 Reading and researching 3

4 Discussions with SMEs 1

5 9f9/2008  Tuesday Application walk through 1

[ Read up standard documents Far research 2

7 Discussion with SME to understand workflow 1

3 Starked creating outline 2

9 Installed application and completed documenting steps 2

10 9/10/2008 Wednesday Created outline and incorporated review comments 3

[ Finish H Cancel

3. The content in the Preview page is selected for translation.
The Preview page models an Excel file. There are tabs corresponding to each Excel

sheet. Each tab contains the following:

Number of preview rows drop down list: to choose the number of rows to be

viewed

Use header check box: select checkbox, if the header row should not be

translated

Table with the Excel sheet contents: select any row to include the selected row
and all rows below for translation. Rows above the selected row will not be

translated.

4. Click Finish .
The configuration and sample file path appears in the Formats Options box as shown in

the screenshot below.
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Preferences [Filtered)

=) General
= Bppearance
Caolors and Fonts
Views
Keys
Memary Preferences
= spelling
Hunspell
Temp Files
=) Translations
Auko-Propagation
Colors
[=)- Filkers
Formats
FrameMaker Filker Prefe
fachine Translation
P Plug-in
Segmentation Settings
=) Terminology
Terminolagy Memary
T Administration
Transcheck
[=)- Translation Memory
Local
Penalties
Remote

Formats

Awailable Formats

i “= Default ASP Filter

| [ DeFault Excel 2007 Filter
@DEFEU": Excel Filker

®  Default HTM Filker

| @  Defaulk HTML Filker

« Default I, Filker

uld Default ISP Filter

«« Default MIF Filker
| 5\ Default POF Fiter
5 Default PowerPaint Filber
Si|Defaulk RTF Filker

«« Defaulk TTX Filker

«« Defaulk TXLF Filker

| [[w! DeFault Yard 2007 Filker

B Def ault wiord Filker

Opkions

Configuration: Simple

Sample File: CiyClient_namelProject_name\Project 11Excel configurationtSta

Defaulk Java Properties Filker

1

| Ty

| Rename
Remawve

Clear ] [ Setup

)

[Restnre Defaults] [ apply ]

[ Ok ][ Cancel ]

5. Click Apply and OK.

An Excel file filter is set up.

Note: You can now directly open Excel files of this type. While opening files you must

choose the correct filter, when prompted. You can also rename the filter using the

Rename button.

Advanced wizard

To run the Advanced wizard:

1. Follow steps 1to 7 from Adding an Excel file filter.
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2. Select Advanced wizard and click Next.

The Preview page appears.

Excel column selection wizard

Preview page

Please select table row to use as column header,

| Sheetl |sheet2 | sheets |

Please chonse number of preview rows, (10 % use headersy
1 Dake Day Ackivity Time taken
z EI2008  Monday Induckion 4
3 Reading and researching 3
4 Discussions with SMEs 1
5 92008  Tuesday Application walk through 1
5] Read up standard documents For research z
7 Discussion with SME ko understand worlkflow 1
g Skarked creating outline 2
a Installed application and completed documenting skeps 2
10 9010y2008 ‘Wednesday Created outline and incorporated review comments 3

[ Finish H Cancel ]

3. The Preview page models an Excel file. There are tabs corresponding to each Excel

sheet. Each tab contains the following:

Number of preview rows drop down list: to choose the number of rows to be

viewed

Use header check box: select checkbox, if the header row should not be

translated

Table with the Excel sheet contents: select any row that should not be translated.
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5.

Click Next.
The Selection page appears.

|| Excel column selection wizard

Selection page

Please select columns For translation.

Shest! | sheet? | sheet3|

Translate  Column name  Targek column
Date

Day

Ackivity

Time taken

oood

[ < Back “ Next =

J

Finish

] [ Cancel

In the Translate column, select the columns for translation.

The corresponding Column name appears in the Target column as shown in the

screenshot below.
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Note: The Target column includes names of columns where the translated text will

appear.
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6. Click Next.

The Regular expression page appears.

7. Enter a Regular Expression for the Excel analysis.
Note: A regular expression provides a pattern to markup any embedded HTML tags or

variables in a column as placeables.

8. Click Finish .
The configuration and sample file path appears in the Formats Options box as shown in
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the screenshot below.

9. Click Apply and OK.
An Excel file filter is set up.
Note: You can now directly open Excel files of this type. While opening files you must
choose the correct filter, when prompted. You can also rename the filter using the

Rename button.

SELECTING FRAMEMAKER FILTER PREFERENCES
The FrameMaker filter preferences must be set before using this filter option.
To set FrameMaker filter preferences:

1. Open Wordfast Pro and click Edit > Preferences > Translations > Filters >
FrameMaker Filter Preferences

The FrameMaker Filter Preferences dialog box appears.
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2. Select the required FrameMaker filter preferences.

Select the corresponding checkboxes to translate reference pages, variables,
cross references and autonumber formatting that appear in the FrameMaker

files.
Enter the maker types that should be excluded from the FrameMaker files.

Enter the conditional tags that must be excluded from the FrameMaker files.

3. Click Apply and OK, to confirm the FrameMaker filter preferences.

(ll + (
In the Analyzing files process, files for translation are analyzed against a translation memory to

leverage reusable content and pre-translate files. This process can greatly improve efficiency and

reduce time and effort spent on translation. Find below the procedures for the following tasks:
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Selecting Analysis output option

Analyzing files

SELECTING ANALYSIS OUTPUT OPTION

When a file is analyzed, an analysis output is generated in the same folder as the source files.
The analysis output is the pretranslated TXML file. The analysis output options allow you to
choose whether the pretranslated TXML file should be renamed to add the language suffix or

placed in a separate folder with a language suffix or both.

To select analysis output option:

1. Open Wordfast Pro and click ~|

The PM perspective appears.

2. Click Edit > Preferences > Translations > PM Plug-in

The Preferences (Filtered) PM Plug-in dialog box appears.
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3. Select a condition to be followed when analyzing files. The options are as follows:

Select

to...

Add language suffix

add the language code (for example ES_MX) as a
suffix to the analysis output file. An example screenshot
of the source folder and the source and analysis output

file is given below.

Subfolder creation

place the analysis output file within a subfolder. An
example screenshot of the source and analysis output

folder and file is given below.

Subfolder creation with

language suffix

place the analysis output file within a subfolder. The
subfolder and analysis output file will also include the
language code as suffix. An example screenshot of the

analysis output folder and file is given below.

ANALYZING FILES

To analyze files:

1. Open Wordfast Pro and click

The PM perspective appears

2. Click Analyze.

The Analyze window appears.

o
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3. Select files from the available list or click , to browse and add files.

The Browse For Folder dialog box appears.

Page 34 of 148



Using PM plug-in

4. Select the folder with the files and click OK.

The Choose Format dialog box appears.

5. Select Add files from subfolders  checkbox if you want to add all files within a folder,
including the files in the sub folders.
6. Select the file Format .

The file Extension appears automatically.
7. Click OK.

The file names appear.

8. Click + to open the folder and select specific files.
Note: You can analyze up to 20 files at a time using Wordfast Pro. If you need to analyze
more files you will have to select them separately or purchase Wordfast Professional
Plus.

9. Select one or more translation memories for analyzing the files.
Note: You will need to add at least one TM before analyzing files. To add a local or

remote TM, click TM Preferences . Go to Creating or opening a TM for more information.
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10. Select Pretranslate and enter the percentage of matches you wish to accept for
pretranslation.
Note: This is an optional step. The percentage defines the minimum leverage required to
pre-translate a specific segment.
You can also specify the analysis output option. For more information, refer Selecting

Analysis output option.

11. Select format for the output report. You have two options:

Output report as comma-separated format: Select this option and click Browse

to select a location and provide a file name as shown in the screenshot below.

Click Save, to save the CSV file. The Analyze window appears with the location

of the CSV file as shown in the screenshot below.

Report format: Select this option to view the output report on-screen
12. Click Analyze .
The analyzed TXML files are saved in the same folder as the source files. According to

the output report format, either a CSV file is saved at the chosen location or the Analysis
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and translation report appears as shown below. The report for files analyzed against

separate TMs appears in separate tabs.

1 + /

In the Extracting frequents process, repetitive source segments are extracted from the files for

translation. Extracting frequents helps reduce the total number of segments to be translated.

Note: The Extract frequents option is available in Wordfast Professional Plus version only.

To extract frequents:

1. Open Wordfast Pro and click ~|

The PM perspective appears
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2. Click Extract Frequents .

The Extract window appears.

3. Select files from the available list or click , to browse and add files.

The Browse For Folder dialog box appears.

4. Select the folder with the files and click OK.

The following confirmation message appears.
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10.

Note: Ensure that the TXML files and the original source files are at the same location.

Click Yes if you want to add files recursively. This ensures that all files within a folder,
including the files in the sub folders are added.

The file names appear.

Select the files from which you want to extract frequents.

Note: Ensure all files selected or added are TXML files.

Click D and select a location for saving the extracted segment and enter a filename
prefix that is easily identifiable.

Enter maximum number of segments per file.

Enter minimum number of repetitions for a segment that you want to extract.

Note: The number signifies the minimum number of times a segment must be repeated in
the set of files to be extracted. For example, if this value is 1, Wordfast Pro will extract
one unique occurrence of all segments that appear once or more.

Click Extract .

The repetitive segments are extracted and saved at the location provided.

Note: The TXML files with extracted frequent segments are sent to the translator for

translation. After translated files are received from the translators, they are cleaned up

Page 39 of 148



Using PM plug-in

and saved into the TM. The TM is then applied to the original TXML files, to complete the
translation process.

( ( #HH"

After files are translated by the translator, they are sent back to the project manager. The PM
then completes the final step of cleaning up the files and updating the TM. Cleaning up is an
automated process, where the source segments are removed and the files are restored to their
original format.

To clean up and update TM:

1. Open Wordfast Pro and click ~|
The PM perspective appears
2. Click Cleanup.

The Cleanup window appears.
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3. Select files from the available list or click , to browse for files.

The Browse For Folder dialog box appears.

4. Select the folder with the files and click OK.

The following confirmation message appears.

Note: Ensure that the TXML files and the original files are at the same location.

5. Click Yes if you want to add files recursively. This ensures that all files within a folder,

including the files in the sub folders are added.
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The files for cleanup appear.

6. Click + to open the file folder and select specific files.
Note: You can clean up to 20 files at a time using Wordfast Pro. If you need to clean up
more files you will have to select them separately or purchase Wordfast Professional
Plus.

7. Select Update TM check box for updating files to a TM. (Optional).

8. Select the translation memory.
Note: You will need to add at least one TM before cleaning up files. To add a local or

remote TM, click TM Preferences . Go to Creating or opening a TM for more information.

9. Select an Update option . The options are as follows:

Select to...

Overwrite existing TU overwrite the existing translation unit.

(default)

Do not overwrite TU not overwrite existing translation unit.

Overwrite if attributes are overwrite the existing translation unit only if custom

identical attributes for new and existing translation units are
identical.

Do not add to TM not add to the translation memory.

10. Select Add Attributes checkbox, to enter custom attributes for the translation unit.
11. Select Add file name as attribute , to add file name as a custom attribute.

12. Select format for the output report. You have two options:
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Comma-separated format: Select this option and click Browse to select a

location and provide a file name

Report format: Select this option to view the output report on-screen

13. Click Cleanup .

A Cleanup report appears.
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di

Translation Memory

Terminology
Window

Hel

=

The options in the File menu are as follows:

Use to...

Create Project... create a new project.

Open Project... open an existing project.

(Ctrl+Shift+P)

Open... (Ctrl+0O) open a new file.
Note: When you browse your PC, only the file
types listed in your File Associations setup
(Window > System Preferences > General >
Editors > File Associations ) will appear.

Open in New open a new file in a new Wordfast Pro window.

Window

Close (Ctrl+W) close the currently open file. If there are unsaved
changes, a warning message appears asking if
you want to save the changes before closing.

Close All close all open files. If there are any unsaved

(Ctrl+Shift+W) changes, a warning message appears asking if
you want to save the changes before closing.

Save (Ctrl+S) save the currently open file.

Save translated save PPT, XLS or DOC files.
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Use to...

file Note: This menu option is activated only when
PPT, XLS or DOC files are saved.

Save As... save and rename the currently open file.

Save All save all the currently open files.

(Ctrl+Shift+S)

Revert revert the file to the state since it was opened, or

since it was last saved, whichever is most recent.

Print (Ctrl+P)

print the file that is currently open.

Properties view information related to the currently open file,
such as the original file format.
Exit exit Wordfast Pro. If there are any files open with

unsaved changes, a warning message appears
asking if you want to save the changes before

exiting.

The options in the Edit menu are as follows:

Use

to...

Undo (Ctrl+2)

undo most recently entered text or performed

function.

Redo (Ctrl-Y)

redo most recently deleted text or re-perform

undone function.

Cut (Ctrl-X)

cut the selected text. This action can be performed

only in the target segment.

Copy (Ctrl-C)

copy the selected text.

Paste (Ctrl-V)

paste the copied text at the location of your cursor.
This action can be performed only in the target

segment.

Select All (Ctrl-
A)

select all the text in the main Translation window.
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Use to...

Find/Replace
(Ctrl-F)

search the current file for text and replace that text
with another text. This action can be performed

only in the target segment.

Spell Check (F7)

check spelling.

Retrieve copy the TM lookup target segment into the file
Selected target segment.
Segment
(Ctrl+Alt+M)
Preferences set translation, translation memory, penalties and
terminology preferences.
( 1 # n
The options in the Translation Memory menu are as follows:
Use to...
New/Select TM create or select a translation memory.
(Ctrl+Shift+N)
Show Whitespace show or hide whitespace characters.
Characters
(Ctrl+Shift+8)

Machine Translation

translate a segment using machine

translation software.

Next Segment
(Alt+Down)

navigate to the next segment. This action
automatically saves the segment to the TM,

if you have edited the translation.

Previous Segment
(Alt+Up)

navigate to the previous segment. This
action automatically saves the segment to

the TM, if you have edited the translation.

Current Segment

Leverage (Alt+Space)

leverage the TM for the current source

segment.

Clear Target Segment
(Ctrl+Alt+X)

clear the text in the target segment.
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Use

to...

Translate Until Fuzzy
(Ctrl+Alt+F)

translate the source segments until there is

a fuzzy match.

Translate Until No

translate the source segments until there is

Match no match.

(Ctrl+Shift+PageDown)

Translate All translate all source segments.
(Ctrl+Shift+End)

Copy Source copy the text from the source segment into

(Alt+Insert)

the target segment.

Expand Segment

combine the currently selected source

(Alt+E) segment with the next segment.
Note: This function can be accomplished
only with segments in the same paragraph.
Segments that have a paragraph break
between them cannot be combined.

Shrink Segment split the source segment into two segments,

(Alt+S) at the location of the cursor.

Confirm All confirm all unconfirmed segments.

Unconfirm All unconfirm all confirmed segments.

Confirm/Unconfirm
Segment (Alt+Enter)

confirm or unconfirm a segment.

Committo TM
(Alt+End)

save the translated segments to the TM and
close the file. This action is typically carried

out when you have completed translation.

Insert LTR Mark

insert Left To Right mark for languages that

use left to right script.

Insert RTL Mark

insert Right To Left mark for languages that

use right to left script.

Copy Placeables

copy all placeables from the source to the

target segment.

Previous Placeable

select the previous placeable in the source
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Use to...
(Ctrl+Alt+Left or segment. The selected placeable will be
Ctrl+Shift+Left) highlighted in red by default.

Remove Placeable
(Ctrl+Alt+Up or
Ctrl+Shift+Up)

delete the currently selected placeable.

Copy Placeable
(Ctrl+Alt+Down or
Ctrl+Shift+Down)

copy the currently selected placeable into
the target segment at the location of the

cursor.

Next Placeable

select the next placeable in the source

(Ctrl+Alt+Right or segment. The selected placeable will be

Ctrl+Shift+Right) highlighted in red by default.

TM Lookup look up the selected source text in the

(Crtl+Shift+T) translation memory. This action leverages
all segments that include that text.

Edit Note... edit a note for a particular segment.

(Alt+Shift+E)

Delete Note delete a note added for a particular

(Alt+Shift+D) segment.

Add Note... add a note for a particular segment.

(Alt+Shift+N)

Analyze (Shift+Space)

analyze the file for translation against a TM
to leverage reusable content and pre-

translate content.

Transcheck verify target segments and view warning
(Ctrl+Shift+Q) messages about missing or incorrect text or
variables.
# ( n

The options in the Terminology menu are as follows:

Use

to...

New/Select Terminology

create or select a terminology.
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Use

to...

Add Term (Ctrl+T)

add a terminology to the terminology list.

Previous Term
(Ctrl+Alt+8 or
Ctrl+Shift+Left)

navigate to the previous terminology in

the source segments.

Copy Term (Ctrl+Alt+0 or
Ctrl+Shift+Down)

copy the selected terminology.

Next Term (Ctrl+Alt+9 or

navigate to the next terminology in the

Ctrl+Shift+Right) source segments.

Edit (Ctrl+E) modify the terminology list.

Import import a terminology list to the open
project.

Export export a terminology list to a location,
either on your computer or a common
server.

The options in the Window menu are as follows:

Use to...

New Window

open a new Wordfast Pro window.

Show View

preview a TXML file in Word, view notes and
the source context. This option also allows you
to add or remove the Outline, TM Lookup and
TXML Context view.

System Options

view and change the system preferences.

Toggle Toolbar

hide or view the toolbar.

- (

The options in the Help menu are as follows:

Use to...

Online Help (F1)

view the Wordfast Pro help.
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Use to...

Bug Report... view or send the error log.

Wordfast Pro find and install new releases and manage

Updates configurations.

Key Assist view all Wordfast Pro functions and keyboard

(Ctrl+Shift+L) shortcuts.

License complete activation of Wordfast Pro and

Management manage license.

About Wordfast Pro view plug-in and configuration details of
Wordfast Pro.
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Translation projects can be managed both by project managers and translators. Managing a

project includes the following tasks:

Creating or opening a project

Creating or opening a translation memory

Importing and exporting terminology lists

Defining penalties

Defining color codes

Enabling spell check

Translating in a project

Deleting a project

&

In Wordfast Pro, it is necessary to create a project before translating a file. You can open a TXML
file for translation only if a project is created or opened. The project is a working environment that
defines settings for the source and target language, translation memory, glossary and other user

information. Find below the procedures for the following tasks:

Creating a project

Opening a project

CREATING A PROJECT

To create a project:

1. Open Wordfast Pro and click |’_E|

The TXML perspective appears.
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2. Click File > Create Project .

The Create Project dialog box appears.

3. Enter a unique Project name .
Note: A unique project name enables differentiation. Naming the project according to the
client name is a good practice. If a unique name is not given, an error message appears
at the bottom of the dialog box.

4. Select Source and Target language .
Note: It is important to select the correct source and target languages. If either of them is
incorrect, Wordfast Pro will not allow you to open files for translation. The languages that
you provide now will be the default language selection for all project files.

5. Click OK.

The Open Project dialog box appears. The project name appears in the Project List and
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the project properties appear at the bottom of the dialog box.

6. Select project name and click OK.

The Preferences (Filtered) dialog box appears.
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The Preferences (Filtered ) dialog box is used for the following tasks:

Selecting translation memory settings. Go to Selecting translation memory settings

for more information.

Creating or opening translation memory. Go to Creating or opening translation

memory for more information.

Importing, exporting, adding, editing and deleting terminology. Go to Importing and
exporting terminology and Working with terminology for more information.

Defining penalties. Go to Defining penalties for more information.

Defining color codes. Go to Defining color codes for more information.

Enabling spell check. Go to Enabling spell check for more information.

OPENING A PROJECT

To open a project:
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#
e =

1. Open Wordfast Pro and click ' ==
The TXML perspective appears.
2. Click File > Open Project .
The Open Project dialog box appears. The project names appear in the Project list and
the project properties appear at the bottom of the dialog box.
3. Select a project name and click OK.
The Wordfast Pro screen appears with the project name on the title bar and the source

and target languages at the bottom of the screen.

( 1 # n
Translation memory (TM) is designed to provide maximum content re-use and facilitate

collaboration between globally distributed localization resources. Translators can leverage

reusable content in two ways:

Local TM: The local TM is located in your system and can only be accessed and updated

by you.

Remote TM: The remote TM is located on a server that can be accessed by several
translators at the same time. The translators can leverage the available content and also

update the TM with new reusable content.
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Find below the procedures for the following tasks:

Selecting translation memory settings

Creating a local TM

Opening a local TM

Exporting a local TM

Creating or opening a remote TM

SELECTING TRANSLATION MEMORY SETTINGS

To select translation memory settings:
1. Open Wordfast Pro and click "‘}
The TXML perspective appears.

2. Follow steps 1 to 6 from Creating a project
Or

Click Translation Memory > New/Select TM

The Preferences (Filtered) dialog box appears.
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3.

In the left pane, click Translation Memory .

The Translation Memory dialog box appears.

Select Copy source on no match checkbox, to copy the source to the target segment, if

there is no match when the TM is leveraged.

Enter the Fuzzy Match Threshold in (%) .

Note: This value signifies the TM leverage percentage limit for a fuzzy match. For

example, if you enter a value of 75%, the tool will mark all the translations which are

leveraged below 75% match as a 'No match' segment.

Select a condition to be followed when editing an existing Translation Unit. The options

are as follows:

Select

to...

Add to TM by overwriting

overwrite the existing translation unit. This
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Select to...

the existing TU (default) option is selected by default.

Add TM; overwrite overwrite the existing translation unit only if
existing TU if attributes custom attributes for new and existing TU are
are identical identical.

Add to TM: do not add to translation memory and not overwrite
overwrite existing TU existing TU

Do notadd to TM not update the TM.

7. Select checkbox to write unedited fuzzy and exact segments to a TM.
Note: This option creates a local TM that can be used on your desktop for local
concordance searching. In this local TM, Machine Translated and fuzzy matches appear
as 100% matches. Therefore, it is suggested that a new local TM is created for this
purpose.

8. Select checkbox to perform TM lookup automatically when navigating from one segment
to the other.
Warning : Automatic TM lookup may affect system performance.

9. Select Use Replaceables for higher TM matches  checkbox to replace numbers that are
in the source to get higher TM matches.

10. Click OK.

The translation memory properties for the project are set up.

CREATING A LOCAL TM
To create a local TM:

1. Follow steps 1 to 2 from section Selecting translation memory settings.
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2. Inthe left pane, select Translation Memory > Local

The Translation Memory - Local dialog box appears.

3. Click New.
The New Local TM dialog box appears.

4. Enter or browse the location for the local TM.
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10.

11.

Enter a file name for the new local TM and click Save.

Enter a Symbolic name for the Local TM.

Note: Ensure that the name is unique and easily recognizable. If a unique name is not
given, an error message appears at the bottom of the dialog box.

Select Source and Target language .

Note: The default source and target languages are the same as the currently open
project. Ensure that the selected TM and project have the same language pair assigned.
If either of them is incorrect, the TM will not be leveraged in the project.

Click OK.

The newly created local TM name appears in the Local TM List and the properties appear

at the bottom of the dialog box.

Select Selected check box, to use the newly created local TM during translation.

Select Read only check box, if you do not want to update the local TM. (Optional)

Click or to prioritize newly created or available local TMs.

Note: Prioritizing TMs will ensure that the first TM in the list is leveraged first, followed by

the remaining TMs.
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12. Click OK.
A new local TM is created for the project.

OPENING A LOCAL TM

To open a local TM:

1. Follow steps 1 to 2 from section Creating a local TM.

2. Click Open.
The Open Local TM dialog box appears.

3. Enter or browse the location of the local TM.

4. Select alocal TM file and click Open.
Note: Ensure that the correct local TM is selected. The local TM file must have a correct
header, which typically includes the creation date, user ID, source and target language
and so on. If an error occurs, please log into the Wordfast Pro support hotline at
www.wordfast.com.

5. Follow steps 6 to 10 from section Creating a Local TM.

An existing local TM is selected for the project.

EXPORTING A LOCAL TM
To export a local TM:

P

1. Open Wordfast Pro and click =),
The TXML perspective appears.
2. Click Translation Memory > New/Select TM

The Preferences (Filtered) dialog box appears.

3. Inthe left pane, click Translation Memory > Local
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4. Select alocal TM and click Export .
The Export Local TM dialog box appears.

5. If required, select another TM from the drop down list.

6. Select the Export Type format of the TM.
Note: You can either choose the default Wordfast Pro TM format or TMX format.

7. Browse to the location where you want to save the exported TM and provide a file name.

8. Click OK.

The TM is exported to the specified location in the chosen format.

CREATING OR OPENING A REMOTE TM

To create or open a remote TM:

1. Follow steps 1 to 2 from section Selecting translation memory settings.

2. Inthe left pane, select Translation Memory > Remote

The Translation Memory - Remote dialog box appears.
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3. Click New or Open.

The New or Open Remote TM dialog box appears.

4. Enter the remote TM URL.
The remote TM information is populated automatically.
5. Alternatively, enter each of the remote TM properties.
The remote TM URL is populated automatically.
Note: The remote TM URL and login details are provided to you by the client, if they are
using a Wordfast TM server.
6. After entering all remote TM information, click Test.
Connection to the remote TM is established and a message appears.
7. Modify the Symbolic name for the remote TM, if required.
Note: The default symbolic name is a combination of the user name, address and port
details.
8. Enter Workgroup ID and Search Depth . (Optional)
Note: The Workgroup ID is a 10 digit number and is provided to you by the Wordfast Pro
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10.

11.

12.

administrator. If a Workgroup ID is not entered, you can only read from the remote TM.
The Workgroup ID is required if you need to update the remote TM.

Ensure that the user name is unique and easily recognizable.

Search depth signifies the number of results that can be viewed for a particular search.
For example, if you are looking for segments containing the word "hotel", only the first
200 segments in the remote TM containing that word will appear.

Enter Timeout Properties .

There are three types of timeouts:
Connection Timeout: controls the connection or disconnection timeout

Short Timeout: controls commands that are expected to be completed
immediately

Long Timeout: controls commands that get serialized in the server's TM queue
and possibly take a long time to complete: searches, updates, concordance
searches and so on.
Select Use Clean Up Password , to provide password to clean up target content and
update the TM.
Note: The password will be provided to you, if you have Project Manager role access
rights.
Select Use TM Admin Password , to provide password and manage TM content.
Note: The password will be provided to you, if you have TM Administrator role access
rights.
Click OK.

The newly created or opened remote TM name appears in the Remote TM List and the
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properties appear at the bottom of the dialog box.

13. Select Selected check box, to use the new remote TM during translation.

14. Select Read only check box, if you do not want to update the remote TM. (Optional)

15. Click or to prioritize newly created or available remote TMs.

16. Click OK.

A new or existing remote TM is created or opened for the project.

# (" (

# 1

A terminology list (or glossary), is a list of source terms and their preferred translations. For

example, a terminology list could include information as follows:

Source

Target

translation memory

mémoire de traduction

translation unit

unité de traduction

data transfer rate

taux de transfert de données
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Source Target
International Fédération Internationale des
Translators Federation Traducteurs

The terminology list is stored as a tab-delimited list of source and target terms on your computer
or a common server. To use a terminology list, you need to import it to Wordfast Pro. After
completing a translation project you also have an option to add new terms and export the term list

to your computer or a common server. Find below the procedures for the following tasks:

Importing a terminologqy list

Exporting a terminology list

IMPORTING A TERMINOLOGY LIST

To import a terminology list:

1. Open Wordfast Pro and click =)
The TXML perspective appears.

2. Click Terminology > Import

The Import terminology dialog box appears.

3. Choose File type . You have two options:
Tab delimited: a TXT file

TBX: an XML file

4. Enter or browse for the terminology file.
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5. Select checkbox to ensure that the first row of the terminology list is viewed as headings.
6. Next, you have two options:

Select Create new terminology, if you are importing the first terminology file for

the project.

Select Import into existing terminology, if you have already imported a

terminology file and want to combine both the files.

Creating new terminology
To create a new terminology list:

1. Follow steps 1 to 4 from Importing a terminology list.

2. Select Create new terminology .

3. Click OK.

The Create new Terminology dialog box appears.

4. Enter Symbolic name , Source language and Target language .

5. Click OK.
A Terminology import message appears confirming the number of terms imported.

6. Click OK.

A new terminology file is created.

Import into existing terminology
To import a new terminology list into an existing terminology list:

1. Follow steps 1 to 4 from Importing a terminology list.

Page 67 of 148



Managing projects

2. Select Import into existing terminology

The Import into existing terminology option is activated.

3. Select the Existing terminology list  for the open project.
4. Select an action, if there is an overlap between the existing and new terminology list.
5. Select Clear before import , if you want to clear all terms in the existing terminology list.
6. Click OK.
The Terminology import report dialog box appears. This describes the number of terms
that will be imported.
7. Click OK.

The new terminology file is imported and a message appears. The terminology list

appears as a separate tab.

EXPORTING A TERMINOLOGY LIST

To export a terminology list:

P

1. Open Wordfast Pro and click =),
The TXML perspective appears.
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2. Click Terminology > Export

The Export terminology dialog box appears.

3. Select Terminology name.

4. Select File type . You have two options:
Tab delimited: a TXT file

TBX: an XML file
The Terminology export report dialog box appears. This describes the number of
terms that will be imported.

5. Enter or browse the location for the terminology file.

6. Click OK.

The terminology list is exported and saved at the specified location.

+ (
Penalties are defined to maintain high quality of the content leveraged from translation memory. A
value is assigned to each of the penalties, which are taken into account to calculate the
translation score. This score is used to differentiate between golden or 100 %, fuzzy and no
match.

To define penalties:

P

1. Open Wordfast Pro and click =),
The TXML perspective appears.
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2. Click Edit > Preferences > Translations > Translation Mem  ory > Penalties .

The Preferences (Filtered) Penalties dialog box appears.

3. Enter values for penalties. Find below the list of penalties and description:

Penalty Description
Case penalizes different case in letters.
Non literal penalization is for punctuations, space, special

characters like apostrophes, dashes, quotes and

soon
Tag penalizes different placeables.
Attribute penalizes if attributes differ.
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+

The color codes are used to differentiate between different types of content in the TXML editor

Penalty Description

Private TU penalizes workgroup Translation Unit (TU).
Public TU penalizes non-workgroup TU.

Local TM penalizes TU from local desktop copy.
Remote TM penalizes TU from remote TM.

Align penalizes TUs coming from an alignment.

Machine translation

penalizes TUs coming from MT.

Multiple
translations

penalizes TUs if there are duplicates within the TM

with different translations.

Match file names

consider filename as an attribute for penalization.

Custom Attribute

consider this attribute name for penalization.

Adaptive Leverage

Correction

converts high fuzzy matches (98% and higher) to
100% matches by ignoring placeables at the start

or end of a segment.

(

workspace.

To define color codes:

#
e =

Open Wordfast Pro and click ' ==,

The TXML perspective appears.

Click Edit > Preferences > Translations > Colors

The Preferences (Filtered) Colors dialog box appears. This displays the default colors
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assigned to different content types.

3. If you want to change the default color for any of the content types, click the colored box.

For example, click the colored box next to Tag color.
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A color palette appears.
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4. Select a color, for example, purple and click OK.

The color code for the selected content changes from blue to purple.

' (o

Enabling the spell check option is a good practice to ensure high quality. Spell check is supported

in Windows and if you have MS Office installed.

To enable spell check:

1. Open Wordfast Pro and click = .

The TXML perspective appears.
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2. Click Edit > Preferences > Spelling
The Preferences (Filtered) Spelling dialog appears.

3. Select Enable spell checking checkbox.

The Hunspell spellcheck engine is automatically selected.
4. Select Check Spelling as you type checkbox. (Optional)
5. Click OK.

The Spell check option is enabled.
Note: To use spell check, click Edit > Spell Check or press F7. The option for choosing

spell check languages is available during installation.
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( &

After you have completed the initial steps of creating project, opening translation memory,
importing terminology and defining penalties and colors, the Wordfast Pro workspace is ready to

be used for translation. The translation process broadly includes the following tasks:
Opening a file

Translating a file

Enabling Machine Translation

Enabling Auto Propagation

Leveraging repetitive content

Working with translation memory

Working with terminology

Working with placeables

Using Transcheck

Confirming or Unconfirming segments

Using Outline window

Viewing TXML Context

Using notes

Saving and closing a file

Using shortcut icons

Modifying colors and fonts

OPENING A FILE

To open a file for translation:
1. Open Wordfast Pro and click "‘}
The TXML perspective appears.
2. Click File > Open File , select file for translation and click Open.
Or
Left-click on the file, and drag and drop into the Translation window.

The file appears in the Translation window.
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Note: Wordfast Pro supports only those TTX files that are translated and segmented

using tag editor. The TTX files must be renamed to match the source format if they need

to be viewed in tag editor.

Find below the description for the various components of the Wordfast Pro workspace:

Number Component Description
1 File name The TXML file name appears here. You
can open multiple files, which appear as
tabs.
2 Source The segment that requires translation
segment appears here.
3 Translation The translation score, which is the
score percentage of match found in the TM
appears here.
4 Target The translated content is entered here by
segment the translator.
5 Views The TXML file can be viewed in two ways,
as plain text and in a table format.
6 TM Lookup The TM leverage results appear here. You
window can also search the TM for a term or a
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Number Component Description

phrase. Go to Using TM Lookup window

for more information.

7 Txml view the TXML context of the currently
Context open file. Go to Viewing TXML Context for

more information.

8 Notes view, edit and delete notes specific to each

segment. Go to Using notes for more

information.
9 Outline The color coded list of all source segments
window appears here. The colors signify the

translation score. Go to Using Outline

window for more information.

TRANSLATING A FILE

This section describes the steps for translating a TXML file when there are no TMs available for
leverage. After entering the new translation for a file, you can save the translation to a new TM,
which can be leveraged at a later stage.

To translate a file:

1. Follow the steps to open a file from section Opening a file.
The file appears in the Translation window. The first translatable segment will appear in a

blue background, and your cursor will be in the target segment by default.
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Note: The placeables in the source segment are marked in grey. For example, {ut1}.
These placeables should be either copied and pasted or typed into the target segment.
They should not be edited or deleted.

Type the target segment.

The typed target segment will appear in a pink background as shown in the screenshot
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below.

3. Select Translation Memory > Next Segment or click or press Alt+Down .
The typed target segment is saved to the TM and the cursor moves to the next segment.

Note: If you need help creating or opening a TM, go to Creating or opening a TM. To
update translation memory with new content, ensure the TM has the Read only check

box clear and update options are selected. Go to Selecting translation memory settings

for more information.
Also note that, the TM will not be leveraged or updated if you press the Enter or Tab

keys or if you click into another segment in the Translation window or the Outline window.

4. After translating all the source segments, select Translation Memory > Commit to TM

or click & or press Alt+End , to update the TM before closing the file.

ENABLING MACHINE TRANSLATION

Wordfast Pro includes an automated machine translation feature which populates translations
whenever a file is open or when there are no translation memory segment matches.

To enable Machine Translation:

1. Open Wordfast Pro and click Edit > Preferences > Translations > Machine

Translation .
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The Machine Translation Preferences dialog box appears.

Select Enable Machine Translation , to populate preset translations.

Select Perform when there is no TM Match , if you want machine translated content to

appear when there are no match segments.
Select Always perform Machine Translation , if you want machine translated content to
appear when you leverage a segment.

To use machine translation, click  or press Alt+Space , click  or press Alt+Down or

click  or press Alt+Up .

The machine translation will appear in the TM Lookup window.
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6. To populate the machine translation in the target segment, click or right-click in the
target segment and click Machine Translation. Find below and example screenshot of a

machine translated file.

Note: Machine translated content is highlighted in orange by default and marked as MT
in the Score column. If required, the default color code can be modified. Refer to Defining

color codes.

ENABLING AUTO PROPAGATION

After source files are analyzed using a TM, you can choose to propagate the 100% matches
automatically. The Auto Propagation option allows you to enable or disable this feature. Enabling
the Auto Propagation option will also allow you to leverage repetitive content. For more

information, refer Leveraging repetitive content.

To enable Auto Propagation:

1. Open Wordfast Pro and click = .

The TXML perspective appears.
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2. Click Edit > Preferences > Translations > Auto-Propagatio  n.

The Auto-Propagation dialog box appears.

3. Select one of the following Auto-Propagation options:
Disable Auto-Propagation: to disable feature

Global Auto-Propagation: to activate auto propagation of all repetitive segments.
This means that if there are multiple segments that have the same content then

editing one segment will auto propagate the change in all matching segments

Partial Auto-Propagation: to activate auto propagation of only those segments
which are not modified. This means that if there are multiple segments that have
the same content and the first and second repetitions are edited, then the
following matching segments will be updated based on the second segment that

was changed.
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4. Click OK.

The Auto-Propagation option is enabled.

Enabling Auto-suggest
The Auto-suggest option populates translations for words based on previously translated content.

To enable Auto-suggest:

1. Open Wordfast Pro and click = .

The TXML perspective appears.
2. Click Edit > Preferences > Translations

The Translations dialog box appears.
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3. Select the Active Autosuggest checkbox and click OK.

LEVERAGING REPETITIVE CONTENT

The leveraging repetitive content option can be used when there are repetitive segments in a file.
For example, if there are multiple instances of the phrase "Our Process" then the translator needs
to type the translation only once. The remaining segments are leveraged automatically. To use
this feature you must enable the Auto Propagation option. For more information, refer Enabling

Auto Propagation.

To leverage repetitive content:

1. Follow the steps to open a file from section Opening a file.
The file appears in the Translation window. The first translatable segment will appear in a

blue background, and your cursor will be in the target segment by default.

Note: There are three instances of the source segment "Our Process".

2. Type the target segment for the first instance.
The typed target segment will appear in a pink background as shown in the screenshot

Page 85 of 148



Managing projects

below.

3. Select Translation Memory > Next Segment or click or press Alt+Down .
The typed target segment is saved to the TM and the subsequent repetitive segments are

leveraged.
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Note: The remaining two instances of "Our Process" are translated automatically.

WORKING WITH TRANSLATION MEMORY

Translation memory (TM) is designed to provide maximum content re-use and facilitate
collaboration between globally distributed localization resources. Find below the procedures for
the following tasks:

Leveraging translation memory

Using TM Lookup window

Updating translation memory

Leveraging translation memory
To leverage translation memory:

1. Follow the steps to open a file from section Opening a file.

The file appears in the Translation window. The first translatable segment will be open,
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and your cursor will be in the target segment by default.

2. Select Translation Memory > Current Segment Leverage  or click or press
Alt+Space .
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The TM will be leveraged and the target segment appears.

Translation memory default color representation

Find below the list of default color representations for source and target segments in the

Translation window:

Color Representation

Blue Source segment
Yellow Fuzzy match

Grey No match or NA
Green 100% match

Pink Segment modified since the

original file was created

Segment modified and
updated to translation

memory

Go to Defining color codes for more information.
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Using TM Lookup window

The TM Lookup window is used to view TM leverage results and context searching. Find below
the procedure for the following tasks:

Viewing TM leverage results

Using TM lookup

Viewing TM leverage results

The TM Lookup window displays the leverage results for the current source segment. The results
display an ID number, source and target segments, the translation score and the translation
memory name.

TM Lookup default color representation

Find below the list of default color representations for source and target segments and translation
score in the TM Lookup window:

Color Representation
Blue Source segment

Yellow Fuzzy match

Green 100% match

Highlighted Words or phrases
text that do not match the

source segment

Go to Defining color codes for more information.

Using TM lookup
TM lookup is a process that searches for specific source segment text in the translation memory.
The results display source and target segments.
To perform TM lookup:
1. Enter a word or phrase in the TM Lookup text box.
2. Click Find In Source or Find In Target .
Note: If you want matches that only have all the words in your phrase, use + signs

between each word instead of spaces. If you use spaces in the search string, then results

Page 90 of 148



Managing projects

will show segments that have any of the words in them.
Or

1. Select a word or phrase in the source segment.

KA
2. Press Ctrl-Alt-L or k2,

The source and target segments appear.

Note: The words or phrases that match the searched context are highlighted.

Updating translation memory
To update translation memory with new content, ensure the TM has the Read only check box

clear and update options are selected. Go to Creating or opening a translation memory and

Selecting translation memory update settings for more information.

When you navigate source segments by pressing Alt+Down or Alt+Up or clicking or
segments are saved automatically to the TM.

Note: If you have changed the target segment, and you navigate using other methods (i.e.,
clicking on other segments to navigate directly to them), a warning message appears asking if

you want to save the target segment.

WORKING WITH TERMINOLOGY

Find below the procedures for the following tasks:
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Setting copy term option

Auto propagating terminology

Using terminology wildcard

Leveraging a terminology list

Adding terminology

Editing terminology

Adding blacklist

Setting copy term option
The copy term option copies the source segment to the target segment.

To set copy term option:

1. Open Wordfast Pro and click "‘}
The TXML perspective appears.
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2. Click Terminology > New/Select Terminology > Translations > Terminology .

The Preferences (Filtered) Terminology dialog box appears.

3. Select one of the following copy term options:

Copy only source: to copy source term from the source segment to the target

segment
Copy only target glossary terms: to copy target term to the target segment

Copy both source and target glossary terms: to copy both source and target

terms to the target segment

Auto propagating terminology
To auto propagate a terminology:

1. Follow the steps to open a file from Opening a file.
The file appears in the Translation window. If a term from the terminology list or glossary

exists in the source segment, it will appear in red by default.
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Note: Ensure that a terminology list is imported and selected for the project. For more

information, refer to Importing a terminology list.

F

Select Translation Memory > Copy Source  or click or press Alt+Insert, to copy the
text from the source segment into the target segment.

The glossary term translation is auto propagated as shown in the screenshot below.

Note: The term 'Process' is followed by its translation 'Proceso’.

Using terminology wildcard

To add and use a terminology wildcard:

1.

Follow the steps to open a file from Opening a file.

The file appears in the Translation window. If a term from the terminology list or glossary
exists in the source segment, it will appear in red by default.

Click Terminology > Edit .

Select the terminology list that you want to edit.

The Terminology list appears.
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4. Double-click on the entry you want to modify.
The Edit term dialog box appears.

5. Type a ™ after the term to populate all variations of the selected term. For example, the
wildcard term 'Process* will populate the target ‘Proceso’ for all term variations such as
'Processes', 'Processing' and so on.

6. Click Modify .

The terminology wildcard is activated.

Leveraging a terminology list
To leverage a terminology list or glossary:

1. Follow the steps to open a file from Opening a file.
The file appears in the Translation window. If a term from the terminology list or glossary

exists in the source segment, it will appear in red by default.

2. Select Terminology > Previous Term / Next Term  or click or or press
Ctrl+Alt+8 / Ctrl+Alt+9  or press Ctrl+Shift+Left / Ctrl+Shift+Right .
The terminology is highlighted and selected.

3. Inthe target segment, place the cursor at the location where you want the translated

terminology to appear.
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4. Select Terminology > Copy Term orclick  or press Ctrl+Alt+0 or Ctrl+Shift+Down .

The translated terminology appears in the target segment.

Adding terminology
To add terminology to a terminology list or glossary:

1. Left-click and select a terminology in the source or target segment.

2. Click Terminology > Add Term or click
The Add to Terminology dialog box appears.

3. Enter Source, Target and Description of the terminology.
4. Select the terminology list that you want to add the terminology to.
5. Click OK.
The new terminology is added.
Editing terminology
To edit terminology:

1. Click Terminology > Edit .
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2. Select the terminology list that you want to edit.

The Terminology list appears.

3. Double-click on the entry you want to modify.

The Edit term dialog box appears.

4. Enter the necessary changes and click Modify .

The modified terminology appears in the terminology list.
Adding blacklist
A blacklist includes words or phrases that should not be used in the target segment.
To add a blacklist:
1. Click Edit > Preferences > Terminology > Blacklist
The Blacklist dialog box appears.

2. Click New, to create a new blacklist or Open, to open an existing blacklist.

Note: the blacklist must be a tab-delimited file.
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3. Browse and select the location of the new blacklist or existing blacklist.
4. Type a symbolic name and select the locale of the blacklist

5. Click OK.

The newly created or selected blacklist appears in the Blacklist List.

6. Select Selected check box, to use the blacklist during translation.

7. Select Read only check box, if you do not want to update the blacklist. (Optional)

8. Click or to prioritize newly created or available blacklists.

9. Click OK.

A new or existing blacklist is created or opened for the project.

WORKING WITH PLACEABLES

A placeable is inline text that is not translatable. For example, HTML code within a sentence.
Target segments should have the same placeables as the source segment, however depending
on the language sometimes a placeable is not needed. If you try to save a target segment with
missing placeables, a warning message appears. Find below an example of a source segment

with two placeables:

Please contact the hotel for further information at {utl}info@companyname.com{ut2}.
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The {utl} and {ut2} text strings represent placeables.

Find below the procedures for the following tasks:

Viewing placeables

Copying placeables

Editing placeables

Deleting placeables

Viewing placeables
To view placeables:
1. Follow the steps to open a file from Opening a file.
The file appears in the Translation window. If a placeable exists in the source segment, it
will appear in gray by default.
2. Place the mouse over the placeable.
The actual text in the placeable appears. Find below an example of the popup for the

{utl} placeable.

Copying placeables
To copy placeables:
1. Follow the steps to open a file from Opening a file.
The file appears in the Translation window. If a placeable exists in the source segment, it
will appear in gray by default.
2. Select Translation Memory > Previous Placeable  / Next Placeable or click or
or press Ctrl+Alt+Left / Ctrl+Alt+Right or press Ctrl+Shift+Left / Ctrl+Shift+Right .
The placeable is highlighted in red and selected.

3. Place the cursor where you want the placeable in the target segment.

4. Select Translation Memory > Copy Placeable orclick or press Ctrl+Alt+Down or
Ctrl+Shift+Down type the characters of the placeable.

The placeable appears in the target segment.
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5. To copy all placeables from the source segment to the target segment, click Translation

Memory > Copy Placeables or click  or press Ctrl+Shift+A .

Editing placeables
To edit placeables:

1. Follow the steps to open a file from Opening a file.
The file appears in the Translation window. If a placeable exists in the source segment, it
will appear in gray by default.

2. Place your cursor in the placeable's text in the target segment, right click and select Edit
Placeable .

The Edit Placeable dialog box appears.

3. Modify the placeable as required and click OK.
Note: The placeable in the source segment should not be modified. Ensure that the
modifications are valid, if not, the TXML file could get corrupted.
Deleting placeables

The placeable can be deleted only in the target segment. To delete placeables, place your cursor

in the placeable's text and select Translation Memory > Remove Placeable or click or press
Ctrl+Alt+Up or Ctrl+Shift+Up .
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USING TRANSCHECK

The Transcheck option verifies certain elements in the target segments and warns you about
missing or incorrect text or variables. For example, if you do not insert a placeable or type

incorrect text, a warning signal will appear before the target segment. You will be able to view the
warning on mouse over.

Find below the procedures for the following tasks:

Enabling Transcheck

Viewing Transcheck warning

Enabling Transcheck

To enable Transcheck:

1. Open Wordfast Pro and click = .

The TXML perspective appears.
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2. Click Edit > Preferences > Translations > Transcheck

The Transcheck dialog box appears.

3. Select Enable Transcheck checkbox.
The Active transcheck checkbox is activated.

4. Select Active transcheck checkbox, if you want transcheck to be activated before the
translation is updated to the TM.

5. To check for specific errors in the target segments, select the different Configuration
options.

The options available are:

Partial: compares the character count between the source and target segments.
Go to Edit > Preferences > Translations > Transcheck > Pa rtial to enter the

minimum and maximum % of allowed character count for the target segment
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Empty Target: checks for an empty target segment

Numerical Check: compares the numerical values between the source and target

segments are correct
Placeable: checks if the placeables are copied correctly to the target segments

Forbidden Chars: checks if the target segment includes forbidden characters. Go
to Edit > Preferences > Translations > Transcheck > Fo  rbidden Chars to add

the forbidden characters that should not be included in the target segment

Punctuations: checks for consistency in punctuation between source and target
segments. Go to Edit > Preferences > Translations > Transcheck >
Punctuations to add the punctuation marks that should not be included in the
target segment

Note: The punctuation transcheck only works on end of segmentation

punctuation.

Untranslatable: compares the source and target segments to check if the
untranslatable content is consistent. Go to Edit > Preferences > Translations >
Transcheck > Untranslatable to add untranslatable text that must be retained in

the target segment

Untranslated Text: checks for untranslated text. For example, if the Copy Source

option was used

Terminology: checks if all terminologies available in the terminology list is

leveraged

Blacklists: checks if the target segment includes blacklisted terminologies. Go to
Edit > Preferences > Terminology > Blacklist  to add blacklisted terminologies
that should not be included in the target segment
Note: The blacklisted terminology list must be a tab delimited file.
6. Choose the display option from the drop down list. You can either view transcheck as an
error or warning.
7. Click OK.

The Transcheck option is enabled.
Viewing Transcheck warning

To view Transcheck warning:

1. Follow the steps to open a file from section Opening a file.

The file appears in the Translation window.
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2. Type the target segment.
A warning message and a warning signal appear before the target segment as shown in

the screenshot below.

3. Place the mouse over the warning signal.

The text in the warning appears as shown in the screenshot below.

Note: The Transcheck warning appeared because the number 101 was incorrectly typed
as 102. The warning signal disappears when the segment is corrected as shown in the

screenshot below.
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CONFIRMING OR UNCONFIRMING SEGMENTS
The Confirm/Unconfirm Segment option allows the translator to mark a segment for future
reference. For example, if the translator wants to check and confirm a segment after referring to
some resources, he or she can mark the segment and revert to it at a later stage.
To confirm or unconfirm a segment:
1. Follow the steps to open a file from section Opening a file.
The file appears in the Translation window. The first translatable segment will appear in a
blue background, and your cursor will be in the target segment by default.
2. Type or leverage the target segment from the translation memory.

The target segment will appear.

3. Click Translation Memory > Confirm/Unconfirm  or “*, to mark the segment.
An *' symbol appears next to the segment in the Outline window as shown in the

screenshot below.

Note: The *' symbol will disappear only when you click Translation Memory >

Confirm/Unconfirm or “% or Alt+Enter again to confirm the segment. Unconfirmed

segments are not committed to the TM when you click Translation Memory > Next
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Segment or  or press Alt+Down or click Translation Memory > Committo TM  or

@ or press Alt+End .

USING OUTLINE WINDOW

The Outline window is used for source segment navigation. The source for each translatable
segment is listed with color coded icons that represent the translation score. The segments that
need to be confirmed are also marked by an asterisk (*) in the Outline window. Find below an

example of an Outline window:

Navigating using Outline window
To view a source segment, in the Outline window, place the cursor on a source segment and left
click.

The source segment is selected and highlighted.

Sorting segments

To sort the source segments, click on the drop down list.

The following options appear:

Page 106 of 148



Managing projects

Outline window default color representation

Find below the list of default color representations for source and target segments in the

Translation window:

Color Representation
Yellow Fuzzy match
Grey No match or NA
Green 100% match
Pink Segment modified

since the original file

was created

Segment modified
and updated to

translation memory

Go to Defining color codes for more information.

VIEWING TXML CONTEXT

The TXML Context window is used to view the TXML context of the currently open file. You also

have the option to view the XML Source. Find below an example of a TXML Context window:
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USING NOTES

While translating or reviewing translated content, you have the option of adding notes specific to

each segment. Find below the procedures for the following tasks:

Adding notes
Editing notes

Deleting notes

Adding notes
To add a note:

1. Follow the steps to open a file from section Opening a file.
The file appears in the Translation window. The first translatable segment will appear in a

blue background, and your cursor will be in the target segment by default.

2. Place your cursor in the segment where you want to add a quote.
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3. Select Translation Memory > Add Note... or click

The Add Note dialog box appears.

4. Enter the note in the box and click OK.

The note appears in the Notes tab and an 'i' symbol appears next to the segment in the
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Outline window as shown in the screenshot below.

Editing notes

To edit notes, you can select Translation Memory > Edit Note...  or right click on the note in the

Notes tab and select Edit Note or click

Deleting notes

To delete notes, you can select Translation Memory > Delete Note... or right click on the note in

the Notes tab and select Delete Note or click

SAVING A FILE

To save a file:
Click File > Save or Ctrl+S, to save the currently open file.
Click File > Save translated file , to save a translated file to its original format.
Click File > Save As , to save and rename the file.

Click File > Save All , to save all open files.

CLOSING A FILE

To close afile:
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Click File > Close or click /& , to close the currently open file.

Click File > Close All , to close all open files.

Note: If you close a file without saving the most recent changes, a warning message

appears querying if you want to save the file.

USING SHORTCUT ICONS

Wordfast Pro includes a number of shortcut icons that help you quickly complete common tasks.

Find below a list of all the shortcut icons available in the TXML Editor and their functionality.

Use

to...

= (Ctrl+0)

open a new file.

Note: When you browse your PC, only the file
types listed in your File Associations setup
(Window > System Options...> General >

Editors > File Associations ) will appear.

=l (ctri+S)

save the currently open file.

= (Ctrl+P)

print the file that is currently open.

(Ctrl+Shift+8)

show or hide whitespace characters.

translate a segment using machine translation

software.

B (cri+shiften)

create or select a translation memory.

Ij’ (Alt+Down)

navigate to the next segment. This action
automatically saves the segment to the TM, if

you have edited the translation.

(Alt+Up)

navigate to the previous segment. This action
automatically saves the segment to the TM, if

you have edited the translation.

H (Alt+Space)

leverage the TM for the current source segment.

YE (CUrl+AIt+F)

translate the source segments until there is a

fuzzy match.
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Use to...

o translate the source segments until there is no
(Ctrl+Shift+PageD | mMatch.

own)

" translate all source segments.
(Ctrl+Shift+End)

F

(Alt+Insert)

copy the text from the source segment into the

target segment.

+ (Alt+E)

combine the currently selected source segment

with the next segment.

Note: This function can be accomplished only
with segments in the same paragraph.
Segments that have a paragraph break

between them cannot be combined.

(Alt+S)

split the source segment into two segments, at
the location of the cursor.

" (Alt+Enter)

mark a segment as confirmed or unconfirmed.

O (Alt+End)

save the translated segments to the TM and
close the file. This action is typically carried out

when you have completed translation.

[

insert left to right mark.

I

insert right to left mark for languages that are

written in that direction, such as Arabic.

copies all placeables from the source segment

to the target segment.

= (Ctri+Alt+Left)

select the previous placeable in the source
segment. The selected placeable will be
highlighted in red by default.

(Ctrl+Alt+Up)

delete the currently selected placeable.

g |

copy the currently selected placeable into the
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Use to...

(Ctrl+Alt+Down) target segment at the location of the cursor.
select the next placeable in the source

(Ctrl+Alt+Right) segment. The selected placeable will be

highlighted in red by default.

= (shift+Space)

analyze the file for translation against a TM to
leverage reusable content and pre-translate
content.

KA _
KX (Ctrl+Shift+T)

look up the selected source text in the
translation memory. This action leverages all

segments that include that text.

atc, (F7) check spelling.
Yy (AIEW) preview the file in MS Word.
(Ctri+Alt+8) navigate to the previous terminology in the
source segments.
(Ctrl+Alt+0) copy the selected terminology.
(Ctri+Alt+9) navigate to the next terminology in the source

segments.

Ev

edit the blacklist for the open project.

I_\:‘_! -
2 T (CUr+E)

modify the terminology list.

EE' (Ctrl+T) add a terminology to the terminology list.
(Alt+Shift+E) edit a note.
(Alt+Shift+D) delete a note.
(Alt+Shift+N) add a note.
(Ctrl+Shift+Q) process file for transcheck warnings.
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MODIFYING COLORS AND FONTS
You can modify the existing colors and fonts for tool layout, TXML editor and View and Editor
folders.

To modify colors and fonts:

#
e =

1. Open Wordfast Pro and click ==,
The TXML perspective appears.
2. Click Edit > Preferences > General > Appearance > Colors  and Fonts .
The Preferences (Filtered) Colors and Fonts dialog box appears. This displays the default

colors and fonts assigned to different content types.

3. If you want to change the default color for any of the content types, click on the content

type.
For example, click on Txml Editor Target Font and click Change .

A font dialog box appears.

4. Select a color and/or font of your choice.
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( &
To delete a project:

1. Open Wordfast Pro and click = .

The TXML perspective appears.
2. Click File > Open Project .
The Open Project dialog box appears.

3. Select a project name and click Delete.
A confirmation message appears, asking if you want to delete the file.

4. Click Yes.

The project is deleted and removed from the Project list.
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The Wordfast Pro advanced options are as follows:

Selecting memory preferences

Defining segmentation settings

Managing shortcut keys

Managing licenses

Updating Wordfast Pro dictionaries

Accented characters

(  ## " +

You can select the maximum memory that Wordfast Pro will use to ensure you can open and

work with large files with ease.

To select memory preferences:
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1. Open Wordfast Pro and click Edit > Preferences > General > Memory Preferences

The Memory Preferences dialog box appears.

2. Select the amount of memory Wordfast Pro will use on your machine and click OK.
Note: Maximum memory is the Java heap size. If the memory size selected here is less

than the available memory, you may get a Java heap size error.

+ #

The Wordfast Pro workspace (.wf_workspace folder) includes a number of default properties files
that are used for file segmentation. You can either use the default properties files or export and

edit these files.
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To define segmentation settings:
1. Open Wordfast Pro and click Edit > Preferences > Translations > Segmentation
Settings .
The Segmentation Settings Preferences dialog box appears.

2. Select the preset segmentation of your choice. The options are:
breaksegmentation.properties
idiomsegmentation.properties
SDLX_Default.srx

wfsegmentation.properties

3. To edit any of the preset segmentations, select the properties file and click Export .
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4. Open the properties file and edit as required.
Note: The commonly used properties file that can be modified is the
wfsegmentation.properties file.

Find below some examples:

Ul description Options Configuration setting

A number followed by segmenter.strategy.trados.rulelenabled
an ESP ends a =true

segment

An ESP without a True/False segmenter.strategy.trados.rule2enabled
trailing space ends a =false

segment. This should
be marked true for

Chinese or Japanese

projects
An ESP followed by a True/False segmenter.strategy.trados.rule3enabled
space followed by a =false

lower-case letter

ends a segment

Simple Tag Handling True/False segmenter.text.simpletaghandling=false
False: causes tags
after the break to
associate left to the
current segment
True: causes Tags
after the break to
associate right to the

next segment

Remove 2 True/False segmenter.simplifier.trados.strict=false

surrounding tags rule.
False: for backwards
compatibility

True: for new projects

Remove trailing tags True/False segmenter.simplifier.trados.noesp=false
that are preceded by
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Ul description

Options

Configuration setting

ESPs.
False: for backwards
compatibility

True: for new projects

End of segment
punctuation for
Trados sentence

iterator

(any
punctuation
separated by
a comma)

ex. .,;,?,l,tab

breakiterator.strategy.sentence.trados.e

sps=.,;,?,!,tab

5. After editing the properties file, click Import to use the edited properties file.

1 O % 1

Wordfast Pro includes a number of shortcut keys that help you quickly complete common tasks.

You can also modify and create new shortcut keys. Find below the procedures for the following

tasks:

Viewing shortcut keys

Modifying shortcut key schemes

Modifying shortcut keys

Creating shortcut keys

VIEWING SHORTCUT KEYS

To view shortcut keys:

1. Open Wordfast Pro and click =),

P

The TXML perspective appears.

2. Click Help > Key Assist or press Cltrl+Shift+L . A list of actions and shortcut keys

appear.

MODIFYING SHORTCUT KEY SCHEMES

To view or modify shortcut key schemes:

#
e =

1. Open Wordfast Pro and click | ==,

The TXML perspective appears.
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2. Click Edit > Preferences .

The Preferences (Filtered) screen appears.

3. Click General > Keys .
The Keys option appears.

4. Select a Scheme from the drop down list.
Note: You can change the shortcut key scheme to Emacs, SDLX, Trados, Wordfast or

Wordfast Classic. You can also create a default scheme of your own.

MODIFYING SHORTCUT KEYS

To modify a shortcut keys:
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1. Follow step 1 and 3 from Modifying shortcut key schemes.

The Keys option appears.

2. Left-click and select a Command.

3. Remove the existing Binding and press a new sequence of keys.

The shortcut key is modified.

CREATING SHORTCUT KEYS

To create a new shortcut key:

1. Follow step 1 and 3 from Modifying shortcut key schemes.
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2. Select Include unbound commands checkbox.

The commands with no shortcut keys appear.

3. Left-click and select a Command.

4. Place the cursor in the Binding field and press a sequence of keys.

A new shortcut key is created.
Find below the procedures for the following tasks:

Re-installing license certificate

Verifying current license certificate

RE-INSTALLING LICENSE CERTIFICATE

To re-install a license certificate:

1. Remove the current version of Wordfast Pro from your PC by running the Uninstaller
located at Start > All Programs > Wordfast Pro > Uninstall
Note: The Uninstaller will also run automatically when you re-install Wordfast Pro.

2. Download the Wordfast Pro installer from the webpage
http://www.wordfast.com/store_download.html to your PC.

3. Runthe installer.
The Wordfast Pro Demo Mode appears.

Note: Wordfast Pro requires a Java JRE to be installed on your PC. During installation, if
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10.
11.
12.

Java JRE does not exist, it will be installed for you. If it exists, then Wordfast Pro will refer
to it when running.

In the Demo Mode, you can view and test all the functions of the software. You can
purchase a Wordfast Pro license from the webpage
http://www.wordfast.com/store_download.html.

If you do not purchase a license, you are limited to storing up to 500 translation units in
your translation memories.

Buy the Wordfast Pro license from the webpage
http://www.wordfast.com/store_download.html.

The license file is sent to you via email.

Save the license file to a known location, preferably C:\Program files\Wordfast Pro.
Open the Wordfast Pro Demo Mode.

Click Help > License Management .

The Activation dialog box appears.

Click License Manager .

Select (Re-)Install a license certificate  and click Next.

Browse and navigate to C:\Program files\Wordfast Pro and select the license file.

Click Next twice and then Finish .

Restart Wordfast Pro.

Your license is active. If you have any problems with the license and require support,

please log into the Wordfast Pro support hotline at www.wordfast.com.

VERIFYING CURRENT LICENSE CERTIFICATE

To verify the current license certificate:

1.

Open Wordfast Pro and go to Help > License Management .

The Activation dialog appears.
Click License Manager .

Select Verify the current license certificate

The license certificate appears. It includes details of the current license.

+

The Update Wordfast Pro option updates the dictionaries that can be used during translation.

To update Wordfast Pro dictionaries:
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1. Open Wordfast Pro and click Help > Wordfast Updates . Wordfast Pro searches for new

updates and the search results appear.

2. Select the features to be installed and click Next.

The license agreement appears.
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3. Select "l accept the terms to the license agreements" and click Next.

The list of features that will be installed appears.

4. |If required, change the location where the features should be installed and click Finish .

The new features are downloaded and your current installation is automatically updated.

5. Restart Wordfast Pro to activate the new dictionaries.

0 0
The table below lists the letters with accents supported by Wordfast Pro.
Accent Sample Shortcut Notes
Acute 006 Ctrl+', V '= apostrophe key
V= any vowel
Circumflex 0o Shift+Ctrl+», V
Grave 0o Ctrl+, V
Tilde N fi Shift+Ctrl+~, Only works with "'n, N, o, O, a,
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Accent Sample Shortcut Notes
Y A"
Umlaut (o)} Shift+Ctrl+:, V := colon key

Example 1: To type the letter 6, hold down the Control key, then press the apostrophe key.

Release both keys and type o. The accented letter should appear.

Example 2: To type the letter O, hold down the Control key, then press the apostrophe key.

Release both keys and type O. The accented letter should appear.

Example 3: To type fi, hold down the Shift key, then the Control key, then the ~ key. Release all

three keys, then type n.

The table below lists the other foreign characters supported by Wordfast Pro.

Symbol Name Shortcut Notes

i Upside-down Alt+Shift+Ctrl+! Either Alt key works.
exclamation point

é Upside-down question Alt+Shift+Ctrl+? Either Alt key works.
mark

C.¢c French C cedille Ctrl+, ,c For ¢, press Control, then
(caps/lowercase) Ctrl+, ,.C the comma key. Release

then press c.

E, e OE ligature Shift+Ctrl+&,0
(caps/lowercase) Shift+Ctrl+&,0

3 German Sharp/Double Shift+Ctrl+&,S
S

g, o Nordic O slash Ctrl+/,0
(caps/lowercase) Ctrl+/,0

A a Nordic A-ring, Angstrom Shift+Ctrl+@,a A with ring/Angstrom Sign
sign (caps/lowercase) Shift+Ctrl+@,A

£, e Old English AE ligature Shift+Ctrl+&,a
(caps/lowercase) Shift+Ctrl+&,A

b, o Old English eth Ctrl+',d Icelandic/Old English eth
(caps/lowercase) Ctrl+',D ' = apostrophe key
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Example 1: To input Spanish upside down exclamation point j (Alt+Shift+Ctrl+!), hold down the
Alt key, then the Shift key, then the Control key, then the ! key. Release all four keys, and the j
punctuation will appear.

Example 2: To input French oe ligature ae (Shift+Ctrl+&,0), hold down the Shift key, then the

Control key, then the & key. Release all three keys and then type o to make the letter appear.

Page 128 of 148



This section includes a list of common errors, their cause and steps that you can follow to solve

them.

Problem: Error message: Invalid license certificate
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Cause: These error messages appear due to the following reasons:
License certificate is not a Wordfast Pro license certificate
License certificate has an incorrect file name or user name
License certificate is edited or some information is missing from the file

License certificate has expired

Solution : Contact the administrator for a new license certificate. You can contact the

administrator by logging into the Wordfast Pro support hotline at www.wordfast.com.

Problem: Error message: TXML source files missing
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Cause: The TXML file and the original file are not at the same location or do not have the same

file name.

Solution : Ensure that the TXML files and the original files are at the same location. If not, the

clean up process cannot be completed.

Problem: Error message: Translation memory headeri s invalid

Cause: The local TM file that is being opened does not have the correct header, which typically

includes the creation date, user ID, source and target language and so on.

Solution : Ensure that the correct local TM is opened. If the error persists, please log into the

Wordfast Pro support hotline at www.wordfast.com.

Problem: Error message: Terminology skipped during import
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Cause: The source or target segment is missing from the terminology list.

Solution : Ensure that the imported terminology list contains the source and target segments of all

the terms.

Problem: Error message: Unable to connect to remote ™
Cause: The URL to the remote TM server is incorrect or invalid.
Solution :
1. Go to Edit > Preferences > Translations > Translation Mem  ory > Remote .

2. Check if the remote TM URL is correct. Find below an example of a URL string:
wf://[french_user:french_password@63.246.29.190:47110

3. Check if there are trailing spaces at the end.

Problem: Error message: Current project and local T M have different source and target
languages
Cause: The source and target languages associated with the currently open project does not
match the local TM language pair.
Solution :

1. Go to Edit > Preferences > Translations > Translation Mem  ory > Local .

2. Select the local TM and click Edit.

3. Change the source and target languages to match the current project language pair.

Problem: Error message: Current project and remote TM have different source and target

languages
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Cause: The source and target languages associated with the currently open project does not

match the remote TM language pair.

Solution :
1. Go to Edit > Preferences > Translations > Translation Memory >R emote.
2. Select the remote TM and click Edit.

3. Change the source and target languages to match the current project language pair.

Problem: Error message: Current project and file fo r translation have different source and

target languages.

Cause: The source and target languages associated with the currently open project does not
match the file language pair.

Solution 1 : Check that you are opening the correct file. If necessary, open the file in a text editor
and view/verify the source and target language specifications.

Solution 2 : Create a new project with source and target languages matching the file for

translation. Go to Creating a project for more information.

Problem: Error message: Current project and termino logy list have different source and

target languages.
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Cause: The source and target languages associated with the currently open project does not

match the terminology language pair.

Solution :
1. Goto Edit > Preferences > Translations > Terminology > Terminol  ogy List .
2. Select the terminology and click Edit.

3. Change the source and target languages to match the current project language pair.

Problem: Translation Memory is not leveraged during translation
Cause: A local or remote TM is not selected.

Solution : Ensure that you are connected to a TM. To confirm go to Translation Memory >
New/Select TM > Local or Remote and check the Selected check box next to the TM you wish

to use. If you have Read only selected, you will not be able to leverage or copy into the TM.

Problem: Shortcut keys not working for key strokes
Cause: The correct scheme is not selected or the shortcut key is not configured.
Solution :
1. Go to Edit > Preferences > General > Keys > Scheme
2. Choose the correct scheme: Wordfast Pro, Emacs, SDLX, Trados, Wordfast or Wordfast
Classic.
3. Check the shortcut key list to ensure that all shortcut keys are configured correctly. If not,

edit accordingly. Go to Managing shortcut keys for more information on viewing,

modifying and creating shortcut keys.

4. Click Apply and OK.
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Wordfast Aligner is an add-on tool that converts existing translated documents into a format that
is compatible with the Wordfast TM. This enables reuse of content translated using other
translation tools and available in different formats. Wordfast Aligner is supported by all operating

systems. This section includes the following:

Using Wordfast Aligner

Basic menu options

Using shortcut icons

+

In Wordfast Aligner a project file (.glp) must be created for each source and target pair. A .glp
includes the source and target documents that need alignment. Alignment is a process by which
the source document segments are matched with the target document segments correctly. Once
aligned, the documents can be exported to create a Wordfast compatible TM.

Wordfast Aligner supports TXML, DOC, PPT and XLS file formats.

To align source and target files and create a Wordfast TM using Wordfast Aligner:

1. Open Wordfast Aligner and click File > New Project or  or Ctrl+N.

The New Project dialog box appears.

2. Complete the following entries:

Option Description

Project Name Enter a unique project name.

Project Location Enter the path or click to select a location for the
project.

Source Path . .
Enter the path or click to select the location of the
source files.

Note: The source files can be in TXML, DOC, PPT and
XLS file formats.

Source Select the source language of the source documents from

Language the drop down list.

Target Path Enter the path or click to select the location of the
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Option Description

target files.

Note: The target files can be in TXML, DOC, PPT and XLS

file formats.
Target Select the target language of the target documents from
Language the drop down list.

3. Click Next.
The File Alignment page dialog box appears.

4. Review the aligned source and target files and update the JDiagram links, if required.

Note: You can select the link and press the Delete button to delete them or drag the
cursor to create new links.

5. Click Finish .

A new project file (.glp) is created and the first document (.gld) in the project appears in
the Project Aligner window as shown in the screenshot below.
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Note: The file alignment is a back-end process that creates automated system links
(JDiagram links) between source and target segments of a document.
6. Review the aligned source and target segments and update the JDiagram links, if

required.
Note: You can select the link and press the Delete button to delete them or drag the
cursor to create new manual links.

7. Click on the Project Explorer button to review all the documents.
Note: In the Project Explorer you can right click on a document name to complete the
following actions: delete, mark as complete or pending. An example screenshot is shown

below.

8. After reviewing all documents click Tools > Export TM or , to create a Wordfast Pro

compatible TM.
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The Export TM dialog box appears.

9. Select the Export Type from the drop down list. The options are:
All documents: includes open, pending and completed documents
Current document: includes currently open document only
Completed documents: includes documents that are marked as complete
10. Enter the TM Name and TM Location .
Note: These options are automatically populated based on the project file name.
11. Enter the TM User.
Note: The TM User is a penalty string that is added to the TM. This will help the user
identify aligned source and target content.
12. Click Finish.
A Wordfast TM is created at the specified location.
#
The Wordfast Aligner basic menu options are as follows:
Use to...
File
New Project create a new project.
(Ctrl+N)
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Use

to...

Open Project
(Ctrl+0O)

open an existing project.

Open Document
(Ctrl+D)

open a document.

Save Document
(Ctrl+S)

save the currently open document.

Close close currently open project or
document.

Exit exit from the tool.

Align

Align All align all segments in the document.

Align Down align all segments below the cursor
position.

Align Up align all segments above the cursor

position.

Reset Alignment

remove existing alignment.

Reset Manual
Links

remove existing manual alignment.

Reset System
Links

remove existing system generated

alignment.

Reset Alignment
Up

remove all alignment above the

cursor position.

Reset Alignment

Down

remove all alignment below the

cursor position.

View

Increase Font

increase the font size.

Decrease Font

decrease the font size.

Previous

Document

navigate to the previous document.
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Working with Wordfast Aligner

Use

to...

Next Document

navigate to the next document.

Project Explorer

View or hide the Project Explorer tab.

Tools

Disable Sync enable or disable sync control. This

Scroll option highlights the source and the
corresponding target segment(s).

Export TM export the aligned documents to
create a Wordfast TM.

Options edit manual and system JDiagram

(Ctrl+Alt+L) link color, choose TM Export Format
and edit fonts based on locales.

Help

Online Help view the online help.

About Wordfast view build and version details for

Aligner Wordfast Aligner.

0

Wordfast Aligner includes a number of shortcut icons that help you quickly complete common
tasks. Find below a list of all the shortcut icons available in Wordfast Aligner and their

functionality.

Use to...
(Ctrl+N) create a new project.
~ (Ctrl+0) open an existing project.

B (Ctrl+D) open a document.

=) (Ctrl+S) save the currently open document.

B align all segments in the document.
align all segments above the cursor
position.
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Working with Wordfast Aligner

Use to...
align all segments below the cursor
position.
G remove existing alignment.
G remove existing manual alignment.
G remove existing system generated

alignment.

remove all alignment above the cursor

position.

remove all alignment below the cursor

position.

remove selected alignment link.

enable or disable sync control. This
option highlights the source and the

corresponding target segment(s).

export the aligned documents to
create a Wordfast TM.

refresh the project aligner. This option
saves changes and reloads the open

projects.

increase the font size.

decrease the font size.

navigate to the previous document.

navigate to the next document.
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Translation Memory Administration perspective provides a simple and user friendly interface to

edit and update translation memories. This section includes the following:

Using TM Administration perspective

Basic menu options

Using shortcut icons

C#
Using TM Administration perspective, users can view, edit and update both local and remote

translation memories. Find below the procedures for the following tasks:

Updating TM Administration preferences

Modifying TM content

UPDATING TM ADMINISTRATION PREFERENCES

To update TM Administration preferences:
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TM Administration perspective

1. Open Wordfast Pro and click | _— |

The TM Administration perspective appears.
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TM Administration perspective

2. Click Edit > Preferences .

The TM Administration Preferences dialog box appears.

3. Update the preferences as required. The TM Administration preferences are:

Option Description

Connect first TM Select checkbox to view the TM content for the first TM in
automatically at the TM Servers list.

startup

Maximum segments Enter the number of segments that you wish to view at a
that can be retrieved time.

at atime

Maximum segments Enter the number of modified segments that you wish to
that can be replaced save at once to the TM.
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TM Administration perspective

Option

Description

at atime

Changed target color

Click on the color box and choose a color to represent
edited TM content.

Ut tag color

Click on the color box and choose a color to represent

placeables.

Keyword match
highlight color

Click on the color box and choose a color to represent

keyword search match.

MODIFYING TM CONTENT

To modify TM content:

1. Double-click on a TM server on the left pane or select a TM and click

The TM content appears in the right pane.

2. Double click on the segment that you wish to modify.

The segment is selected and highlighted in pink. You can change the color by updating

the TM Administration preferences.
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TM Administration perspective

3. Type the new translation and click &

#
The Wordfast Pro Translation Memory Administration perspective basic menu options are as
follows:
Use to...
File
Exit exit from the tool.
Edit
Preferences... set general, spelling, translation,
translation memory, penalties
and terminology preferences.
TM Server
Connect connect to a TM server.
Disconnect disconnect from a TM server.

Reversed Sort Order

reverse the TM Servers order in

the left pane.

Sort By

sort TM Servers based on

different criteria.

TM Content

Previous Placeable
(Ctrl+Alt+Left)

select the previous placeable in
the source segment. The
selected placeable will be
highlighted in red by default.

Remove Placeable

delete the currently selected

(Ctrl+Alt+Up) placeable.
Copy Placeable copy the currently selected
(Ctrl+Alt+Down) placeable into the target

segment at the location of the

cursor.

Next Placeable

select the next placeable in the
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Use to...

(Ctrl+Alt+Right) source segment. The selected
placeable will be highlighted in
red by default.

Discard All undo all segment changes.

(Ctrl+Alt+Home)

Discard Selected
(Ctrl+Alt+PageUp)

undo selected segment changes.

Update Selected

update selected segment

(Ctrl+Alt+PageDown) changes to the TM.

Update All update all segment changes to
(Ctrl+Alt+End) the TM.

Window

New Window

open a new Wordfast Pro

window.

System Options

view and change the system

preferences.

Help

Online Help (F1)

view the Wordfast Pro help.

Bug Report...

view or send the error log.

Wordfast Pro

find and install new releases and

Updates manage configurations.

Key Assist view all Wordfast Pro functions
(Ctrl+Shift+L) and keyboard shortcuts.
License complete activation of Wordfast
Management Pro and manage license.

About Wordfast Pro

view plug-in and configuration
details of Wordfast Pro.
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TM Administration perspective

0

Wordfast Pro TM Administration perspective includes a number of shortcut icons that help you

quickly complete common tasks. Find below a list of all the shortcut icons available in Wordfast

Pro Administration perspective and their functionality.

Use to...

P open TM administration preferences.
(Ctrl+Shift+C) create a TM server connection.
(Ctrl+Shift+D close a TM server connection.

= (Ctri+Alt+Left)

select the previous placeable in the source
segment. The selected placeable will be
highlighted in red by default.

] (Ctrl+Alt+Up)

delete the currently selected placeable.

Q (Ctrl+Alt+Down)

copy the currently selected placeable into the

target segment at the location of the cursor.

select the next placeable in the source segment.

(Ctrl+Alt+Right)
The selected placeable will be highlighted in red
by default.
(Ctrl+Alt+Home) undo all segment changes.
undo selected segment changes.
(Ctrl+Alt+PageUp)
4 update selected segment changes to the TM.
(Ctrl+Alt+PageDown)
(Ctrl+Alt+End) update all segment changes to the TM.
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